ログイン
ユーザ名:

パスワード:


パスワード紛失

新規登録
Main Menu
« 1 (2)
スレッド表示 | 新しいものから 前のトピック | 次のトピック | 下へ
投稿者 スレッド
webadm
投稿日時: 2009-6-23 1:16
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
日立のHDD
Express 5800を立ち上げてみたところどうも具合がおかしい。

例の日立のHDDの欠陥ブロックが発生するたびにSCSIコントローラーのリセットが入るためシステムそのものがフリーズする。

そして恐れていたシステムファイルが収まっていたブロックが新たに欠陥ブロックとなり、それらが正常に読めなくなる(途中欠けるのでロードされても正常に動作しない)。

見た目はまともそうな日立のHDDだけど、5台とも同じような症状。どうも電源を入れて回転し始めた最初の頃にエラーが多発する傾向がある。

ヤフオクでも同じ型式のU160の日立製HDDがraid用に使われていたセットで売りに出ている。似た様な症状でお払い箱になった可能性が疑われる。結構良い値段している。

秋葉原に久々にいったらデパート地下でU160やU320の80pinのものが結構安く売られていた。試しに買ってみようと思ったけど、また漬け物石がひとつ出来るのではという予感で止めた。

やはりまともなPATAのドライブを手にいれてそれをシステムドライブにしてSCSIアレイはraidを組むしかないか、それでもあれだけの頻度で欠陥ブロックを生成してくれるとパフォーマンス的に使い物にならんような。

いずれにせよ今ブート用にしているドライブの状態は酷く、インストールしてあるパッケージもいくつか損傷を受けてアンインストールもできない(エラーが多発でrootファイルシステムがroでremountされてしまうため)。
webadm
投稿日時: 2010-4-11 17:22
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
dist-upgradeしたら立ち上がらなくなった
だいぶアップデートをしていなかったので久々にapt-get dist-upgradeしたのだが立ち上がらなくなった。

正確には立ち上がるもののGRUBがrootファイルシステムを見つけられないということでbusyboxプロンプトになってしまうという症状。

元々このExpress5800は古いSCSIディスクシステムなので最新のGRUB2とかも使えないのだが8.04から8.10にアップグレードしただけで支障が出てしまった。

busyboxプロンプトに戻ってしばらくするとディスクのアクセス音がガガっとして、それ以前までは/dev/配下そのものが存在しなかったのが忽然と現れる。それ以降であればbusyboxを抜ければ正常に立ち上がる。

devファイルシステムの仕組みが新しくなって時間がかかるようになったのだろう。

busy-boxに落ちる前に表示されるメッセージにrootdelayうんぬんをカーネルコマンドラインに指定してみたらとか書いてあるので、grubのメニューファイルのdefaultoptionにrootdelay=90を追加してupdate-grubを実行してメニューエントリに反映されていることを確認。

再起動すると以前よりも

Loading please wait...

の時間が長くなり、その間に例のガガというHDDアクセス音がして程なくして正常に立ち上がった。

やれやれ。古いサーバー機のお守りも大変だ。




webadm
投稿日時: 2010-6-30 22:44
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
debian再インストール
立ち上がらなくなってしまったサーバー機に仕方なくdebianを再インストールしようと試みた。

結果は、何故かインスーラーが既存のファイルシステムをスキャンしに行くところでkernel panic...orz

こういうところにまだ脆弱性が残っているのか。

一端raidコントローラにドライブアレイをつなぎ直してインストールするとbootloaderを書き込むまでは順調に進んだ。

しかし前からそうだけどGRUBもLILOも書き込むことができない。というよりもraid driveだとドライブユニットをリストするスクリプトでリストに追加されない。意図してなのかバグなのか。

これは既知の問題なので、元のマザーボード上のSCSIコントローラにつなぎ換えて再びインストール開始。

今度はすべて順調に行った。dist-upgradeしたdebianは潰してしまったのか無くなっていて、もうひとつubuntu8は残っていた。

確認のためにGRUBメニューからubuntu8の残骸をブートしてみたら立ち上がった。ユーザー環境もそのまま残っていた。これはこれでよかった。

新たにインストールし直したdebianも立ち上がった。こちらは基本システムしか入っていないので、sshとか諸々を追加インストールしてリモートで入れるようにしてとりあえず準備は完了。

立ち上がらなくなったのは単純にバッドブロックが発生してしまったためだろう。そもそもこのドライブは全部エラーが多すぎ。使っている間にどんどん壊れていきそうな感じ。

安いIDEドライブかSATAシステムを入れるか迷うところ。

とりあえず使えるサーバーができた。
webadm
投稿日時: 2010-10-7 20:17
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
Re: 日立のHDD
ずっとソフト開発用のビルドマシンとして無停止稼働していたExpress 5800のHDDが芳しくなくなった。

以前は見たことがない症状が出始めた。

最初に異常がわかったのは、apt-get installをした際にPerl moduleの一部が壊れていることが発覚。代替処理が失敗したらしい。

実はapt-getとかdebianのパッケージ管理はperl moduleに依存していて、それがないとにっちもさっちもいかない。どんどん未処理のパッケージがバックログとして貯まる。

仕方ないので、perlを単独でソースからビルドしてインストールした。これでdebianパッケージ管理機能が使えるようになった。


もうこのおんぼろSCSIドライブを使うのはやめて、内蔵ATA HDDにしたほうがよいのかもしれない。もしくはSATA I/F拡張ボートを挿して使うとか。

しかし最近の拡張カードはPCIxだったりするんだよな...orz
webadm
投稿日時: 2013-4-10 22:37
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
SSDをこうた
近所のPC Depoを久々に覗いたら、既にPATA HDDは店頭から消えていた(ノД`)シクシク

いやExpress serverのSCSI HDDアレイが寿命なので使っていないPATAポートにHDDを入れてブートドライブにしようかと常々考えていたんだが、それも今は適わなくなった。

そうするとSATAインタフェースでも増設してそこにSATAドライブをつなぐしかない。

と思って増設ボードのコーナーに行くと、なんとそこにPATA-SATA変換ボードなる商品があるではないか。2種類あって、ひとつはSATAポートが2つでPATAポートはPATA HDDと同様にIDEケーブルでマザーボードと接続するタイプ。こちらも拡張性としては魅力的ではある。しかし良く考えたらIDEの片方のドライブはCD-ROMがつながっている気がするのでこれはだめくさい。

もうひとつはマザーボードのPATAコネクタ直挿しできるタイプのもの。昔COMPACT FLASHとIDEの変換ボードとかで同じような形態のものがあったが、それのSATA版。実際には比べ者にならないぐらい高級でPATAとSATAのプロトコル変換チップが基板に載っているので、電源が別に必要となる。

やはりドライブはSSDだろう。ということで一番安い安心できるIntel製の60Gドライブを併せて購入。

さて帰宅してさっそく試してみようと思ってExpressサーバーを開封してPATAのコネクタを探すが見つからない。どっかにあったはずなんだが。

そのまましばらくほっておいて、また思い出した頃に拡張スロットのカバーを外してみたらマザーボードのはじっこにあった。Floppyの拡張用とIDEの拡張用と思われるコネクタを発見。その近くに別の2.5inch用とおぼしきコネクタがあるが同時に使えるのかよくわからず。それ以外にも謎のピンヘッダ列があって用途は不明。

とりあえずここに挿せばいいということは確認できた。

SATAケーブルやドライブへの電源ケーブルはSATA-IDE変換ボードに付属していた。それらを予め接続。

問題はドライブとボードの電源だが、3.5inch HDD用の電源からの供給ケーブルとの接続ケーブルが付属している。

しかしここで問題発生。

Expressサーバー内蔵の電源には3.5inch HDD用の電源ケーブルなど用意されていないのだった。

元々SCSI HDDアレイ内蔵なので、そのための専用電源コネクタがあるだけ。PATAポートは余っているが、現実的にそこにドライブを接続するというのは考えられていないようだ。収納スペースもないし当然といえば当然。

フロントパネル面には別のHDDドライブスペースがあるが、こちらは特殊なコネクタ接続。もしかしてバックアップ用のテープドライブとかを想定しているのだろうか。

というわけで電源を別に用意しないといけないということになった。

しかし昔とった杵柄でHDD用の電源はいくつも持っていた。

それをつないで準備OK

あとはSSDにUbuntuをインストールするだけ。

開始すると問題なくUbuntuインストールCDが立ち上がったが、古いCD-ROMドライブなので起動が遅い。インストールも遅そうな予感。

あと問題なのが最近のUbuntuはディスプレイの解像度がSVGAでは足らないらしい。

今までつないでいた7インチのSVGAモニターでは解像度が合わずインストール操作ができない。

しかたないので別のPCの液晶ディスプレイをもってきてつないだ。

それでようやくインストール開始。

特に異常もなくインストール完了。

もうSCSI HDDアレイは用済みなんだけど、しばらくはバックアップとしてつないでおくか。

さすがにSSDなのでSCSI HDDとは比べ者にならないほど起動が早い。

当面は壊れる心配はないだろう。

そういえばこの60GのSSDを買ってレジに行った際に、横目に60GのUSB HDDとかが目にはったが見なかったことにした。値段は当然USB HDDの方が安いわけだけど。古いPCサーバーだとUSB 2.0が使える期待は薄いので忘れることにしよう。

しかしすごい時代になった。中古の300MBのSCSI HDDを秋葉原で手にいれてほくそ笑んでいたのはついこの前のような気がする。

当時は10Mとか20Mとかの内蔵HDDですら10万とかしていた時代だし。

webadm
投稿日時: 2013-8-9 23:21
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
Re: SSDをこうた
帰宅してExpressサーバー経由でアルバイト仕事のログファイルを転送しようとしたら、サーバーに接続できない。

おかしいなSSHでのターミナルセッションは生きているのにどうしたんだろう。

と思って別のPCからFTPサーバーにつなごうとしたらやっぱりつながらない。

生きているSSHセッションからサーバーの状態を確認しようとコマンドうつとどれもまともに動かない。

どうしたんだヘイヘイヘイ

Expressサーバーのコンソールディスプレイのところにいってマウスを操作すると、マウスしか出てこない。

ファイルを書こうとするとread-onlyだと怒られる。

どうやら重度のディスク障害が発生したようだ、昨日の夜中はなんともなかったのに。

しかたないので強制電源オフで再起動してみることに。

しかしディスクドライブが見つからない。

SSDがsetupメニューからも認識されていないことが明らか。

SSDが逝ったのか

良くみたら、SSDのSATAインタフェースとサーバーのPATAを変換するアダプタボードのLEDが点灯していない。これが故障したのか。

いやよくよく見たら、変換ボードとSSDに電源を供給する外付けの古いHDD用電源のLEDが消えているのに気づいた。

こいつか

正常であれば電源端子付近にある基板上の赤いLEDが点灯するはずだが消えている。

おんぼろHDD電源が逝ったくさい。

大分長いつきあいだったけど、昔はSCSIの300MBのHDDとかその後はCD-ROMドライブとかいろいろ活躍した。今は出番がなくなって、ようやく最後のお勤めであるSSDとSATA-PATA変換基板の大事な電源として働いてもらっていたけど、ついに寿命か?

ちゃんと最後は爆発炎上ではなく、静かに息を引き取るけなげさ。

いったい死因はなんだろうと、さっそく検屍解剖を

その結果驚愕の事実が明らかに。

てっきりどこか内部がショートしてヒューズが溶断してfail safeな故障かと思ったら違っていた。



写真に移った基板の手前部分に明らかに電解液漏れの症状が。手前から2番目の中央の電解コンデンサの天井が膨らんでいるのが確認できる。このコンデンサから大量の液漏れが発生して、基板の半分ぐらいが電解液で浸食されていた。

死因は末期の電解液漏れによる多臓器不全だった。

もう少し早く気づいていれば電解コンデンサを交換するだけで済んでいたのにと思うと残念である。

労力をかけて基板を洗浄、電解コンデンサを交換しても復活するかどうかは保証の限りではないので、死亡確定ということに。

バッテリーがピンピンではなかったのだった。

しかし代わりの電源を探さないといけない。そういえばメインPCから摘出したATX電源があるが、あれも負荷をかけると電源が入らないとかいう病気持ちだけど。

とりあえずそれで代替することに。

いやはや夏はいろいろ壊れる

機械にも寿命がある。でも寿命が来る時までの事は考えていない設計者が最近は多い。それではだめだと思う。

webadm
投稿日時: 2013-8-11 15:44
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
Re: SSDをこうた
昨日秋葉原に出かけて、HDD用電源を探したが今はもうそんな電源が放出されているはずもなく、鈴商に電流容量はちょっと不足だけどHDD電源モジュールが圧着ピンコネクタキット付きで900円で軒先に売られていたのでそれを調達。

翌日に圧着ピンは適当なツールが無いので、直接基板にケーブルをハンダ付けすることに。

そうやってSSDとSATA-IDE変換基板の電源にしてみたが、ドライブを認識しない。

しかもIntel SSDはちんちんに熱くなってるし。こんなに電流食うのか。確かに中には高性能ARM SoCが内蔵されているからそうかもしれない。

やはり電流容量が足らないようだ。他のSATA HDDをつないでもうんともすんともしない。

仕方ないので、メインPCから摘出したATX電源を引っ張りだすことに。

HDD電源ケーブルを接続してPow onピンをGNDに落とすと、立ち上がらない(´Д`;)

そういえば電源の一次側スイッチを入れてなかったかも、正解。

無事青色LEDが点灯して電源がONに。

Expressサーバーを電源オンしたらBIOS Setup画面にSSDが認識されている。そのままbootしたら、あっという間にUbbuntuが立ち上がった。

しかしSSDはエコではないことが判ってしまった。

そういえば以前からチンチンに熱くなっていたのには気づいていたが。

さて電源をどうするか、振り出しに戻ってしまった。

SSDもSATA-IDE変換基板も5Vしか使用しないのが判っているので、適当な5Vスイッチング電源を直接5V電源につないでしまえばいいのだ。ただし電流容量はPC電源並が要求される。
webadm
投稿日時: 2013-11-26 14:38
Webmaster
登録日: 2004-11-7
居住地:
投稿: 2943
Ubuntuアップデート後立ち上がらなくなった...orz
Expressサーバーにログインするたびにubuntuアップデートがrebootを要求しているのを放置していたので久々にrebootしたら立ち上がらなくなった...orz

カーネルとかがアップデートされたらしいのでそれが原因くさい。

とりあえず駄目そうなので一端電源を落として騒音を解消し熟睡。

翌日に再び起動したところ、SSDそのものは問題なくGrubのブートメニューも表示されるが最新のカーネルをbootしようとするとアクセスLEDが薄ぼんやり点いたままで固まる。

仕方がないので、以前のカーネルをメニューから開いて一つ前のものを起動してみるテスト

問題なく瞬時に立ち上がった、そら以前問題なく使えていたのだから当然。

そろそろ古いマシンもサポートされなくなったか、動作チェックを誰もしなくなった可能性が大きい。

今のExpressも32bitマシンなので、そろそろ64bitマシンが欲しいところ。またしても粗大ゴミがひとつ出来上がってしまうのだが、なんとも居たたまれない。昔i286からi386に時代が変わった時の感傷が再び蘇る。まだ使えるのに。

そういえば職場に64bit AMDワークステーションとサーバーが使われずに放置されていた。以前はSolarisの仕事で使ったのだけど、その後用なし状態。あれを持ってくるか、でもまたサポートされなくなったらやだな。

以上
« 1 (2)
スレッド表示 | 新しいものから 前のトピック | 次のトピック | トップ

投稿するにはまず登録を
 
サイト内検索